Important Update: Community URLs redirect issues are partially resolved. Learn More. .

Showing results for 
Search instead for 
Did you mean: 

JS Transporter Summit Lab

Contributor III

I recently started testing the JS Transporter and found the Google API lab document Scott posted from a 2018 summit. I am having a credentials error when trying to run the data feed.

Any one know why this may be? I am using version 6.10 


Archer Employee
Archer Employee

@matthancock, did you create the Google News API key, JavaScript Transporter Lab Guide - RSA Archer Summit 2018.docx - Archer Community - 556879 ( around page 4 and update the key in data feed?

 Advisory Consultant

Yes, I created an account and a key as instructed.

I brought in the following...

  • Application: JavaScript Transport Lab
  • Service Account: jsLabDfManager 
  • apiKey: generated
  • keyword: Company
  • publishDate: 2022-04-05

Results: Faulted: An unexpected error has occurred: Unable to login with specified credentials

Is there any issue with service account?

Contributor III

I generated a new key and still get the same credential error.

Check the Archer Job logs to see if there anything specific.

Do other non-JS data feeds run without a problem?

 Advisory Consultant

other jobs run with no issues.

is there another JS Transport example I could possible try?

What does the job log say when the feed faults?

 Advisory Consultant

Nothing shows in the logs.

Does your server environment need to go through a proxy for internet access?

 Advisory Consultant

A proxy is in place. In most transporters the proxy settings are in the data feed itself, but not for JS transporter, where would I put proxy information in?

I tried running the same data feed from the lab on our 6.4 environment and it jumps from Pending to Terminating and just sits there. 

I did get to the log file from 6.4 and got an error.

<Description>SCRIPT_RUNTIME_ERROR : One or more errors occurred.Error in HTTP Response: HTTP ERROR: Error: getaddrinfo ENOTFOUND