Important Update: Community URLs redirect issues are partially resolved. Learn More. .

Showing results for 
Search instead for 
Did you mean: 

Mail Merge via API returning Javascript output

Contributor III

I am trying to perform a mail merge via the API process however the [PerformMailMerge] output is returning some type of Javascript after  couple of minutes (see below) instead of a byte array. 

Note: I am using the Archer API Template to perform this'/RSAarcher/Default.aspx';
window['adrum-start-time'] = new Date().getTime();
config.appKey = 'EUM-AAB-AWG';
config.adrumExtUrlHttp = '';
config.adrumExtUrlHttps = '';
config.beaconUrlHttp = '';
config.beaconUrlHttps = '';
config.xd = {enable : true};
})(window['adrum-config'] || (window['adrum-config'] = {}));


When I check the status of the process using [CheckAsyncMailMergeProgress] it always returns 0.

The steps that I am taking are: 

  1. StartAsyncMailMerge
    • Returns the [exportId]
  2. PerformMailMerge
    • Returns the javascript above
    • I expected some type of number
  3. CheckAsyncMailMergeProgress
    • Returns a 0
    • I expected to see a 100 (edit: after the document was returned, this displayed a 100)
  4. GetAsyncMailMergeDocument
    • Returns empty output
    • I don't know what I expected

Is this an error or am I not performing the action correctly?



Apparently I did something correctly because I eventually received an email with a link to the document. But I still have a couple of clarifying questions.

  1. Am I performing the correct steps in the correct order?
  2. Do I need to wait until [CheckAsyncMailMergeProgress] returned 100 before running [GetAsyncMailMergeDocument] or can I run this at any point AFTER I run the [PerformMailMerge] and it will just send me a link when it's complete?

I think what confused me was the output of the [PerformMailMerge]. It lead me to believe that it didn't process successfully. 

Any additional information would be helpful.