Showing results for 
Search instead for 
Did you mean: 


Contributor II

Hi All,

I am trying to use webservices API to Perform Mail Merge. I am using the below code. But I am getting this error. Please let me know what I can do to fix it.


$ps = New-WebServiceProxy -Uri $api_url1 -Class Record -Namespace webservice
[Byte[]] $mailmerge= $ps.PerformMailMerge($session_token, 256146 , 1);



Exception calling "PerformMailMerge" with "3" argument(s): "Server was unable to process request. ---> There was an error
performing the mail merge. ---> There was an error performing the Mail Merge but no failure was reported to Web Service.
Additional information can be found in the log file."
At line:37 char:1
+ Byte[] $mailmerge= $ps.PerformMailMerge($session_token, 256146 , 1);
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (:) [], MethodInvocationException
+ FullyQualifiedErrorId : SoapException




Jeff LettermanDavid Petty


Archer Employee
Archer Employee

Pooja, have you looked and the Archer Jobs or Archer W3WP logs to see if there's further details about why it failed?

 Advisory Consultant


I'm new to archer and I am not aware of Archer Jobs or W3WP logs. Can you please guide me how to navigate to them?

Is it from Archer back-end or is there any report for failed logs?

Pooja, the logs are on the back-end and you'd have to check the Archer Control Panel (back-end) to see where they are located.

 Advisory Consultant

Thanks David,

Unfortunately I do not have access to Control Panel. I have tried both PerformMailMerge and GetAsyncMailMergeDocument Webservices calls.

both run into an infinite loop of Bytes.

I tries to use Jeff Letterman's API toolBox as well. The script ran into an infinite loop there as well.


Jeff Letterman

Are you calling StartAsyncMailMerge first?

 Advisory Consultant

Yes, I used StartAsyncMailMerge to get the exportId first

At this point Pooja, it's hard to tell what's going on without looking at the logs.


Does running the mail merge through the UI work without any issues?

 Advisory Consultant

Contributor II

Thanks David Petty for all the inputs. I have got this working now. There seemed to have been a glitch in the backend and the PerformMailMerge() worked after a few days on it's own.


Although my purpose has been served using PerformMailMerge(), there is still a something wrong with GetAsyncMailMergeDocument Webservices call.

Glad to help Pooja.


I'd open a ticket with support on GetAsyncMailMergeDocument call and see if it's known defect or not.

 Advisory Consultant