cancel
Showing results for 
Search instead for 
Did you mean: 
ThomasFritts
Archer Employee
Archer Employee

You're in the middle of creating an advanced workflow.  You've double-checked everything, set up your layouts, created your notifications, and done everything necessary to get your advanced workflow to a "complete" state.  The only issue?  When you create a record to test your workflow, the workflow service fails.  So you go through and check the settings on the server, try to create a package of the application, and any number of other things to fix the problem, but everything seems to be set up correctly and there’s no visible reason why workflow should not be functioning.

 

I went through this exact situation recently and found the answer to my problems in what seemed to be an unlikely place: looping transitions.  Before we jump in, let me direct your attention to the help page for Advanced Workflow that covers (in step 3) creating looping transitions: https://vendor.ironmountain.com/Archer/Help/en/HTML-Help/Content/Platform/Workflow/wrkflw_building.htm. Here’s a snippet from that page: “In most cases you do not need to do anything to change a transition into a looping transition. As you build an advanced workflow, the system attempts to detect loops and automatically convert transitions to looping transitions as necessary. However, in some cases the system may not detect that you have drawn a loop, particularly if you delete and redraw a looping transition. In this case, you need to manually change the transition to a looping transition.” This news spelled trouble for me because I have a tendency to not get things right the first time a build a workflow, and need to make minor tweaks. Now we can get back to the story.

 

I was using a loop to create a "rejection workflow".  Initially, advanced workflow had tried to label the looping transition for me and placed it in the middle of what I would consider my “loop”. After testing a record, something wasn’t right and the advanced workflow on the record kept failing. After my failed attempts, I went back to the drawing board and labeled all of my transitions in my loop as “looping”. I went back to the end user side of RSA Archer and tested a record, and again my record would not process through the advanced workflow.

 

As part of my troubleshooting process I tried many different things to fix the not-so-apparent error. I rebuilt my workflow node-by-node and as I rebuilt my workflow I changed the first transition in my rejection workflow to a “Looping Transition” and the issue presented itself again. You can see in the image below that the dotted line, aka the looping transition, is the first transition in the rejection part of the workflow.

 

1.png

 

As I continued to troubleshoot, I moved nodes and transitions around in my workflow and advanced workflow, once again attempted to determine which transition it thought should be the looping transition. Even though advanced workflow was attempting to determine was supposed to be the looping transition, the record processing failures still occurred.

Finally, I decided to try manually placing the looping transition in the final position, as seen below.

2.png

After making this final change, my workflow processed without error.

The biggest discovery here for me was that, despite advanced workflow not throwing an error on the administration side, an issue seemed to be preventing advanced workflow from operating correctly, and in fact seemed to throw errors that would lead me to examine the services on the server. By doing a little investigation into the configuration of my workflow, I was able to determine that the labeling of looping transitions is critical to the success or failure of a workflow even if your record is not in that stage of the workflow when it fails. 

I’d recommend remembering it this way: your looping transition is the transition that finishes the loop. While other transitions may lead you down the loop path, the final transition completes the loop.

Good luck, and happy looping!

4 Comments