cancel
Showing results for 
Search instead for 
Did you mean: 
Security Advisories
Review security announcements regarding the Archer products

Articles

Archer Update for Multiple Vulnerabilities

Archer Identifier SA-5 CVE Identifier CVE-2022-37317, CVE-2022-37318 Severity High Severity Rating See below for scores of individual CVEs Affected Products Archer Platform versions greater than 6.x Summary Archer Platform contains fixes for multiple...

MegONeil by Archer Employee
  • 2566 Views
  • 0 comments
  • 2 kudos

Archer Update for Improper Access Control

Archer Identifier SA-3 CVE Identifier CVE-2022-37316 Severity Medium Severity Rating CVSSv3.1 Base Score: 6.5 (AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N) Affected Products Archer Platform versions greater than 6.8 Summary Archer Platform versions great tha...

MegONeil by Archer Employee
  • 1558 Views
  • 0 comments
  • 0 kudos

Archer Update for Multiple Vulnerabilities

Archer Identifier SA-2 CVE Identifier CVE-2022-30584, CVE-2022-30585, CVE-2021-33615 Severity Critical Severity Rating See below for scores of individual CVEs Affected Products Archer Platform versions greater than 6.x Summary Archer Platform contain...

MegONeil by Archer Employee
  • 4812 Views
  • 0 comments
  • 1 kudos

Archer Security Advisory: Okta Breach

Archer Identifier SA-4 Applies To Okta Publication: https://www.okta.com/blog/2022/03/updated-okta-statement-on-lapsus/ Details Archer utilizes Okta for internal corporate SSO and has been developing (but has not yet deployed) Okta use relative to it...

MegONeil by Archer Employee
  • 704 Views
  • 0 comments
  • 6 kudos
Special advisories related to CVEs with broad industry interest even when we know our products and platforms are not affected.   Applies To Commons.Apache.org Publication: https://lists.apache.org/thread/n2bd4vdsgkqh2tm14l1wyc3jyol7s1om  CVE Details: CVE-2022-42889    Details Archer is aware of the Apache Commons Text Vulnerability (CVE-2022-42889) disclosed on October 13, 2022. The following components are not affected: • Archer Application • Archer SaaS and Archer Hosted • Archer Engage for Vendors • Archer Engage  • Archer Regulatory Content Analysis • Archer Insight Legal Information Read and use the information in this Archer Security Advisory to assist in avoiding any situation that might arise from the problems described herein. If you have any questions regarding this advisory, contact Archer Technical Support. Archer distributes Archer Security Advisories in order to bring to the attention of users of the affected Archer products, important security information. Archer recommends that all users determine the applicability of this information to their individual situations and take appropriate action. The information set forth herein is provided "as is" without warranty of any kind. Archer disclaims all warranties, either express or implied, including the warranties of merchantability, fitness for a particular purpose, title and non-infringement. In no event shall Archer, its affiliates or its suppliers, be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Archer, its affiliates or its suppliers have been advised of the possibility of such damages. Some jurisdictions do not allow the exclusion or limitation of liability for consequential or incidental damages, so the foregoing limitation may not apply.
View full article
Archer Identifier SA-5   CVE Identifier CVE-2022-37317, CVE-2022-37318   Severity High   Severity Rating See below for scores of individual CVEs   Affected Products Archer Platform versions greater than 6.x   Summary Archer Platform contains fixes for multiple security vulnerabilities that could potentially be exploited by malicious users to compromise the affected system.   Details Archer Platform has been updated for the following vulnerabilities: • HTML Injection Vulnerability CVE-2022-37317 Archer Platform 6.x before 6.11 P3 contain a HTML injection vulnerability. An authenticated remote attacker could potentially exploit this vulnerability by tricking a victim application user to execute malicious code in the context of the web application. 6.10 P4 (6.10.0.4) and 6.11 P2 HF4 (6.11.0.2.4) are also fixed releases. CVSSv3.1 Base Score: 7.6 (AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:L) • Reflected Cross-site Scripting Vulnerability CVE-2022-37318 Archer Platform 6.9 SP2 P2 before 6.11 P3 (6.11.0.3) contain a reflected XSS vulnerability. A remote unauthenticated malicious Archer user could potentially exploit this vulnerability by tricking a victim application user into supplying malicious JavaScript code to the vulnerable web application. This code is then reflected to the victim and gets executed by the web browser in the context of the vulnerable web application. 6.10 P4 (6.10.0.4) and 6.11 P2 HF4 (6.11.0.2.4) are also fixed releases. CVSSv3.1 Base Score: 7.0 (AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:L) For more information about any of the Common Vulnerabilities and Exposures (CVEs) mentioned here, consult the National Vulnerability Database (NVD) at http://nvd.nist.gov/home.cfm. To search for a particular CVE, use the database’s search utility at http://web.nvd.nist.gov/view/vuln/search.   Recommendation For CVE-2022-37317, the following Archer releases contain a resolution to this vulnerability: • Archer version 6.11 P3 (6.11.0.3) or higher • Archer version 6.11 P2 HF4 (6.11.0.2.4) or higher • Archer version 6.10 P4 (6.10.0.4) and subsequent 6.10 releases For CVE-2022-37318, the following Archer releases contain a resolution to this vulnerability: • Archer version 6.11 P3 (6.11.0.3) or higher • Archer version 6.11 P2 HF4 (6.11.0.2.4) or higher • Archer version 6.10 P4 (6.10.0.4) and subsequent 6.10 releases Archer recommends all customers upgrade at the earliest opportunity.   Severity Rating For an explanation of Severity Ratings, refer to the Archer Vulnerability Disclosure Policy. Archer recommends all customers consider both the base score and any relevant temporal and environmental scores which may impact the potential severity associated with particular security vulnerability.   EOPS Policy Archer has a defined End of Primary Support policy associated with all major versions. Please refer to the Product Version Life Cycle for additional details.   Legal Information Read and use the information in this Archer Security Advisory to assist in avoiding any situation that might arise from the problems described herein. If you have any questions regarding this advisory, contact Archer Technical Support. Archer distributes Archer Security Advisories in order to bring to the attention of users of the affected Archer products, important security information. Archer recommends that all users determine the applicability of this information to their individual situations and take appropriate action. The information set forth herein is provided "as is" without warranty of any kind. Archer disclaims all warranties, either express or implied, including the warranties of merchantability, fitness for a particular purpose, title and non-infringement. In no event shall Archer, its affiliates or its suppliers, be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Archer, its affiliates or its suppliers have been advised of the possibility of such damages. Some jurisdictions do not allow the exclusion or limitation of liability for consequential or incidental damages, so the foregoing limitation may not apply.      
View full article
Archer Identifier SA-3   CVE Identifier CVE-2022-37316   Severity Medium   Severity Rating CVSSv3.1 Base Score: 6.5 (AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N)   Affected Products Archer Platform versions greater than 6.8   Summary Archer Platform versions great than 6.8 contain an Improper Access Control vulnerability in a multi-instance system that could potentially be exploited by malicious users to compromise the affected system.   Details Archer Platform has been updated for the following vulnerabilities: • Improper API Access Control Vulnerability CVE-2022-37316 Archer Platform 6.8 before 6.11 P3 (6.11.0.3) contains an improper API access control vulnerability in a multi-instance system that could potentially present unauthorized metadata to an authenticated user of the affected system. 6.10 P3 HF1 (6.10.0.3.1) is also a fixed release. For more information about any of the Common Vulnerabilities and Exposures (CVEs) mentioned here, consult the National Vulnerability Database (NVD) at http://nvd.nist.gov/home.cfm. To search for a particular CVE, use the database’s search utility at http://web.nvd.nist.gov/view/vuln/search.   Recommendation For CVE-2022-37316, the following Archer Platform releases contain a resolution to this vulnerability: • Archer version 6.11 P3 (6.11.0.3) or higher • Archer version 6.10 P3 HF1 (6.10.0.3.1) and subsequent 6.10 releases Archer recommends all customers upgrade at the earliest opportunity.   Severity Rating For an explanation of Severity Ratings, refer to the Archer Vulnerability Disclosure Policy. Archer recommends all customers consider both the base score and any relevant temporal and environmental scores which may impact the potential severity associated with particular security vulnerability.   EOPS Policy Archer has a defined End of Primary Support policy associated with all major versions. Please refer to the Product Version Life Cycle for additional details.   Legal Information Read and use the information in this Archer Security Advisory to assist in avoiding any situation that might arise from the problems described herein. If you have any questions regarding this advisory, contact Archer Technical Support. Archer distributes Archer Security Advisories in order to bring to the attention of users of the affected Archer products, important security information. Archer recommends that all users determine the applicability of this information to their individual situations and take appropriate action. The information set forth herein is provided "as is" without warranty of any kind. Archer disclaims all warranties, either express or implied, including the warranties of merchantability, fitness for a particular purpose, title and non-infringement. In no event shall Archer, its affiliates or its suppliers, be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Archer, its affiliates or its suppliers have been advised of the possibility of such damages. Some jurisdictions do not allow the exclusion or limitation of liability for consequential or incidental damages, so the foregoing limitation may not apply.      
View full article
Archer Identifier SA-2   CVE Identifier CVE-2022-30584, CVE-2022-30585, CVE-2021-33615   Severity Critical   Severity Rating See below for scores of individual CVEs   Affected Products Archer Platform versions greater than 6.x   Summary Archer Platform contains fixes for multiple security vulnerabilities that could potentially be exploited by malicious users to compromise the affected system.   Details Archer Platform has been updated for the following vulnerabilities: • Improper Access Control Vulnerability CVE-2022-30584 Archer Platform 6.3 before 6.11 (6.11.0.0) contains an Improper Access Control Vulnerability within SSO ADFS functionality that could potentially be exploited by malicious users to compromise the affected system. 6.10 P3 (6.10.0.3) and 6.9 SP3 P4 (6.9.3.4) are also fixed releases. CVSSv3 Base Score: 9.6 (AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H) • REST API Authorization Bypass Vulnerability CVE-2022-30585 The REST API in Archer Platform 6.x before 6.11 (6.11.0.0) contains an Authorization Bypass Vulnerability. A remote authenticated malicious user could potentially exploit this vulnerability to view sensitive information. 6.10 P3 (6.10.0.3) and 6.9 SP3 P4 (6.9.3.4) are also fixed releases. CVSSv3.1 Base Score: 8.0 (AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N) • Remote Code Execution Vulnerability CVE-2021-33615 Archer Platform 6.x before 6.11 (6.11.0.0) contains a Remote Code Execution Vulnerability. A remote authenticated malicious user could potentially exploit this vulnerability to gain access to files that should only be allowed by extra privileges. 6.10 P2 (6.10.0.2) and 6.9 SP3 P4 (6.9.3.4) are also fixed releases. CVSSv3.1 Base Score: 8.0 (AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H) For more information about any of the Common Vulnerabilities and Exposures (CVEs) mentioned here, consult the National Vulnerability Database (NVD) at http://nvd.nist.gov/home.cfm. To search for a particular CVE, use the database’s search utility at http://web.nvd.nist.gov/view/vuln/search.   Recommendation For CVE-2022-30584, the following Archer Platform releases contain a resolution for this vulnerability: • Archer Platform version 6.11 (6.11.0.0) or higher • Archer Platform version 6.10 P3 (6.10.0.3) and subsequent 6.10 CPRs • Archer Platform version 6.9 SP3 P4 (6.9.3.4) and subsequent 6.9.3 CPRs For CVE-2022-30585, the following Archer Platform releases contain a resolution for this vulnerability: • Archer Platform version 6.11 (6.11.0.0) or higher • Archer Platform version 6.10 P3 (6.10.0.3) and subsequent 6.10 CPRs • Archer Platform version 6.9 SP3 P4 (6.9.3.4) and subsequent 6.9.3 CPRs For CVE-2021-33615, the following Archer Platform releases contain a resolution for this vulnerability: • Archer Platform version 6.11 (6.11.0.0) or higher • Archer Platform version 6.10 P2 (6.10.0.2) and subsequent 6.10 CPRs • Archer Platform version 6.9 SP3 P4 (6.9.3.4) and subsequent 6.9.3 CPRs Archer recommends all customers upgrade at the earliest opportunity.   Credit Archer would like to thank Mandiant, Angelo Alviar, Michael Maturi, and Troy Knutson for reporting CVE-2021-33615.   Severity Rating For an explanation of Severity Ratings, refer to the Archer Vulnerability Disclosure Policy. Archer recommends all customers consider both the base score and any relevant temporal and environmental scores which may impact the potential severity associated with particular security vulnerability.   EOPS Policy Archer has a defined End of Primary Support policy associated with all major versions. Please refer to the Product Version Life Cycle for additional details.   Legal Information Read and use the information in this Archer Security Advisory to assist in avoiding any situation that might arise from the problems described herein. If you have any questions regarding this advisory, contact Archer Technical Support. Archer distributes Archer Security Advisories in order to bring to the attention of users of the affected Archer products, important security information. Archer recommends that all users determine the applicability of this information to their individual situations and take appropriate action. The information set forth herein is provided "as is" without warranty of any kind. Archer disclaims all warranties, either express or implied, including the warranties of merchantability, fitness for a particular purpose, title and non-infringement. In no event shall Archer, its affiliates or its suppliers, be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Archer, its affiliates or its suppliers have been advised of the possibility of such damages. Some jurisdictions do not allow the exclusion or limitation of liability for consequential or incidental damages, so the foregoing limitation may not apply.      
View full article
Archer Identifier SA-1   CVE Identifier CVE-2021-41594, CVE-2021-33616, CVE-2021-38362, CVE-2022-26948, CVE-2022-26949, CVE-2022-26950, CVE-2022-26947, CVE-2022-2695   Severity Medium   Severity Rating See below for scores of individual CVEs   Affected Products Archer versions greater than 6.x   Summary Archer contains fixes for multiple security vulnerabilities that could potentially be exploited by malicious users to compromise the affected system.   Details Archer has been updated for the following vulnerabilities: • Improper Access Control Vulnerability CVE-2021-41594 Archer 6.x through 6.9 SP3 P2 (6.9.3.2) contains an improper access control vulnerability. A remote authenticated malicious user could potentially exploit this vulnerability to gain access to API information that should only be allowed by extra privileges. CVSSv3 Base Score: 4.8 (AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:N/A:N) • Stored Cross-Site Scripting Vulnerability CVE-2021-33616 Archer 6.x through 6.9 SP1 P4 (6.9.1.4) contains a stored XSS vulnerability. A remote authenticated administrative Archer user could potentially exploit this vulnerability to store malicious HTML or JavaScript code in a trusted application data store. When application users access the corrupted data store through their browsers, the malicious code gets executed by the web browser in the context of the vulnerable web application. CVSSv3 Base Score: 6.3 (AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N) • REST API Authorization Bypass Vulnerability - CVE-2021-38362 The REST API in Archer 6.x through 6.9 SP3 (6.9.3.0) contains an authorization bypass vulnerability. A remote authenticated malicious user could potentially exploit this vulnerability to view sensitive information. CVSSv3 Base Score: 6.5 (AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N) • Insecure Credential Storage Vulnerability with RSS feed – CVE-2021-26948 The Archer RSS feed integration for Archer 6.x through 6.9 SP1 (6.9.1.0) is affected by an insecure credential storage vulnerability. A malicious attacker may obtain access to credential information to use it in further attacks. CVSSv3.1 Base Score: 5.8 (AV:P/AC:H/PR:L/UI:R/S:U/C:H/I:L/A:H) • Improper Access Control Vulnerability – CVE-2022-26949 Archer 6.x through 6.9 SP2 P1 (6.9.2.1) contains an improper access control vulnerability on attachments. A remote authenticated malicious user could potentially exploit this vulnerability to gain access to files that should only be allowed by extra privileges. CVSSv3 Base Score: 5.3 (AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N) • Open Redirect Vulnerability – CVE-2022-26950 Archer 6.x through 6.9 P2 (6.9.0.2) are affected by an open redirect vulnerability. A remote unprivileged attacker may potentially redirect legitimate users to arbitrary web sites and conduct phishing attacks. The attacker could then steal the victims’ credentials and silently authenticate them to the Archer application without the victims realizing an attack occurred. CVSSv3 Base Score: 5.4 (AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N) • Cross-site Scripting Vulnerability CVE-2022-26947 Archer 6.x through 6.9 SP3 (6.9.3.0) contains a reflected XSS vulnerability. A remote authenticated malicious Archer user could potentially exploit this vulnerability by tricking a victim application user to supply malicious HTML or JavaScript code to the vulnerable web application; the malicious code is then reflected back to the victim and gets executed by the web browser in the context of the vulnerable web application. CVSSv3 Base Score: 6.3 (AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N) • Cross-site Scripting Vulnerability CVE-2022-26951 Archer 6.x through 6.10 (6.10.0.0) contain a reflected XSS vulnerability. A remote SAML unauthenticated malicious Archer user could potentially exploit this vulnerability by tricking a victim application user to supply malicious HTML or JavaScript code to the vulnerable web application, the malicious code is then reflected back to the victim and gets executed by the web browser in the context of the vulnerable web application. CVSSv3 Base Score: 6.5 (AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N)   Recommendation For CVE-2021-41594, the following Archer releases contain a resolution to this vulnerability:      • Archer version 6.9 SP3 P3 (6.9.3.3) or higher For CVE-2021-33616, the following Archer releases contain a resolution to this vulnerability:      • Archer version 6.9 SP2 (6.9.2) or higher For CVE-2021-38362, the following Archer releases contain a resolution to this vulnerability:      • Archer version 6.9 SP3 HF1 (6.9.3.0.1) or higher For CVE-2022-26948 (CE-5808), the following Archer releases contain a resolution to this vulnerability:      • Archer version 6.9 SP1 P1 (6.9.1.1) or higher Note: This security issue was fixed in 6.9 SP1 P1 but introduced a product regression fixed in 6.9 SP2 P1 (CE-9723), so we recommend installing 6.9 SP2 P1 or higher if you utilize the impacted functionality. For CVE-2022-26949, the following Archer releases contain a resolution to this vulnerability:      • Archer version 6.9 SP2 P2 (6.9.2.2) or higher For CVE-2022-26950, the following Archer releases contain a resolution to this vulnerability:      • Archer version 6.9 P3 (6.9.0.3) or higher For CVE-2022-26947, the following Archer releases contain a resolution to this vulnerability:      • Archer version 6.9 SP3 P1 (6.9.3.1) or higher For CVE-2022-26951, the following Archer releases contain a resolution to this vulnerability:      • Archer version 6.10 P1 (6.10.0.1) or higher Archer recommends all customers upgrade at the earliest opportunity.   Credit Archer would like to thank Mariani Francesco for reporting CVE-2021-41594. Archer would like to thank Mandiant, Angelo Alviar, Michael Maturi, and Troy Knutson for reporting CVE-2021-38362. Archer would like to thank Mandiant, Angelo Alviar, Michael Maturi, and Troy Knutson for reporting CVE-2021-33616.   Severity Rating For an explanation of Severity Ratings, refer to the Archer Vulnerability Disclosure Policy. Archer recommends all customers consider both the base score and any relevant temporal and environmental scores which may impact the potential severity associated with particular security vulnerability.   EOPS Policy Archer has a defined End of Primary Support policy associated with all major versions. Please refer to the Product Version Life Cycle for additional details.   Legal Information Read and use the information in this Archer Security Advisory to assist in avoiding any situation that might arise from the problems described herein. If you have any questions regarding this advisory, contact Archer Customer Support. Archer distributes Archer Security Advisories in order to bring to the attention of users of the affected Archer products, important security information. Archer recommends that all users determine the applicability of this information to their individual situations and take appropriate action. The information set forth herein is provided "as is" without warranty of any kind. Archer disclaims all warranties, either express or implied, including the warranties of merchantability, fitness for a particular purpose, title and non-infringement. In no event shall Archer, its affiliates or its suppliers, be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Archer, its affiliates or its suppliers have been advised of the possibility of such damages. Some jurisdictions do not allow the exclusion or limitation of liability for consequential or incidental damages, so the foregoing limitation may not apply.  
View full article
Top Contributors